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Gi i thi uớ ệ

Gi i thi uớ ệ
Chương này sẽ bao gồm cách sử dụng các form trong các tài liệu Writer. Phần lớn các thông 
tin ở đây được ứng dụng và form trong các thành phần OpenOffice.org khác, nhưng có một 
vài sự khác biệt.

Chương này biểu diễn thông tin về cách sử dụng form trong bốn mục chính: thiết lập một 
form cơ bản, một ví dụ cho  việc tạo form, liên kết một form với một nguồn dữ liệu và cuối 
cùng một vài kỹ thuật cao hơn.

Các form OpenOffice.org bao trùm rất nhiều vấn đề và không phải mọi thứ đều được đề cập 
đến ở đây. Sự thiếu sót đáng kể là việc sử dụng form ở trong các tài liệu HTML và các 
macros viết để liên kết đến các điều khiển form.

Khi nào s  d ng formử ụ
Một tài liệu văn bản chuẩn hiển thị thông tin: một bức thư, một báo cáo hoặc sách nhỏ để 
quảng cáo... Thông thường một người đọc có thể chỉnh sửa tuỳ thích. Một form có các mục 
không bị chỉnh sửa, và một số mục khác được thiết kế để cho người đọc thay đổi.Ví dụ, một 
bản câu hỏi có phần giới thiệu và câu hỏi và khoảng trống cho người đọc điền câu trả lời.

OpenOffice.org đưa ra một vài cách để điền thông tin vào một biểu mẫu, bao gồm cả hộp 
kiểm tra checkbox, hộp văn bản text box, danh sách kéo xuống pull-down list và vòng quay 
spinner.

Các biểu mẫu được sử dụng trong ba cách:

• Để taọ một biểu mẫu đơn giản đối với người nhận để hoàn thành, ví dụ như bảng câu 
hỏi được gửi cho một nhóm người để điền vào và gửi trả.

• Để liên kết một cơ sở dữ liệu hoặc một nguồn dữ liệu và cho phép người sử dụng nhập 
thông tin. Một người nào đó điền thông tin cho từng yêu cầu vào một cơ sở dữ liệu sử 
dụng biểu mẫu.

• Để xem thông tin được tổ chức trong cơ sở dữ liệu hoặc nguồn dữ liệu. Một người 
thông minh nên xem thông tin về các cuốn sách.

Sử dụng các biểu mẫu để  truy cập cơ sở dữ liệu cho phép một cách nhanh và dễ dàng để xây 
dựng một giao diện đồ hoạ phức tạp. Biểu mẫu của bạn có bao gồm bất cứ trường nào liên 
kết với nguồn dữ liệu  mà còn văn bản, đồ hoạ, bảng, hình vẽ và các thành phần khác.

Các thay đổi trong việc sử dụng biểu mẫu trong Writer
Trong OpenOffice.org phiên bản 1.x, các biểu mẫu chỉ là cách để truy cập nguồn dữ liệu. 
Trong phiên bản 2.0 Base các thành phần cung cấp một cách khác để đạt điều này. Có rất 
nhiều sự tương đồng giữa các biểu mẫu trong Base và Writer, nhưng nó có thể là một cách tốt 
hơn đối với một nhiệm vụ cụ thể. Base chỉ dùng cho biểu mẫu truy cập nguồn dữ liệu, bạn 
không sử dụng nó cho các biểu mẫu đơn giản.

Using Forms in Writer 1



Khi nào s  d ng formử ụ

OOo2.0 bây giờ bao gồm Base-thành phần cơ sở dữ liệu. Bạn có thể tạo cơ sở dữ 
liệu vào biểu mẫu trong Base.

Phần lớn các thành phần OpenOffice.org khác-Calc, Impress và Draw- cũng hỗ trợ biểu mẫu 
giống như Writer làm.

Tạo một form đơn giản
Phần này giải thích cách tạo môt form đơn giản không cần liên kết đến nguồn dữ liệu hoặc cơ 
sở dữ liệu và không có những thao tác cao cấp.

Tạo một tài liệu
Không có cách nào đặc biệt để tạo tài liệu được sử dụng như biểu mẫu. Tạo một tài liệu 
Writer mới với File > Nes > Text document.

Form toolbars Các thanh công cụ biểu mẫu
Hai thanh toolbar điều khiển việc tạo form: Form Control và Form Design. Lựa chọn Select 
View > Toolbars > Form Controls and View > Toolbars > Form Design để hiện thị cả hai. 
Xem “Form controls reference” ở trang 7 cho tóm tắt các công cụ trong các thanh công cụ.

TIP

Chỉ dẫn
Thanh toolbar Form Design có thể đồng thời được lấy ra từ thanh toolbar Form 
Controls. Một vài điều khiển ít sử dụng nằm trong thanh toolbar thứ ba – More 
Controls cũng được lấy ra từ thanh toolbar Form Controls.

Figure 1: The three form design toolbars

Thanh toolbar Form Controls có một nút cho từng kiểu sử dụng nhiều nhất của điều khiển.

Note

Chú ý
Trong form OpenOffice.org, các điều khiển là các hộp văn bản, các hộp danh sách, 
các nút lựa chọn, các nút ấn và các mục khác có thể được thay thế trong các biểu 
mẫu.
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T o m t form đ n gi nạ ộ ơ ả

Kiểu thiết kế
Khi tạo một form, bạn sẽ muốn kiểm tra tất các các phần của công việc form trực tiếp. Nếu 
kiểu thiết kế bị tắt, form sẽ cư xử như là đối với người sử dung cuối. Các nút có thể được ấn, 
hộp checkboxes được đánh dấu và các mục danh sách được lựa chọn. Nếu kiểu thiết kế đang 
bật, nhấn và mục điều khiển lựa chọn cho việc chỉnh sửa.

Nhấn vào nút Design Mode  trên thanh công cụ Form Controls để chuyển trạng thái 
thiết kế từ bật sang tắt hoặc ngược lại.

TIP

Chỉ dẫn
Nếu nút Design Mode không sẵn sàng, nhấn vào nút Select. Điều này sẽ kích hoạt 
phần lớn các công cụ trong ba thanh công cụ.

Thêm các điều khiển form
1) Để thêm một điều khiển form vào một tài liệu, nhấn để lựa chọn một điều khiển. Con 

trỏ chuột sẽ chuyển sang hình dạng:

2) Nhấn vào trong văn bản nơi bạn muốn điều khiển xuất hiện (Bạn có thể thay đổi vị trí 
của điều khiển sau đó)

3) Giữ nhấn trái chuột, kéo điều khiển để điều chỉnh kích cỡ của nó.

4) Nút điều khiển vẫn còn kích hoạt, bạn có thể   thêm các điều khiển khác của cùng loại 
mà không cần thực hiện các thao tác đối với thanh công cụ.

5) Để thanh đổi một công cụ khác, nhần vào hình tượng của nó trên thanh công cụ.

Để dừng việc thêm các điều khiển, nhấn vào nút Select  trên thanh công cụ Form 
Control, hoặc nhấn vào một trong các điều khiển bạn vừa thêm. Con trỏ chuột sẽ thay 
đổi trở lại thành trạng thái xuất hiện ban đầu.

TIP

Chỉ dẫn
Giữ phím Shift khi đang tạo một điều khiển biểu mẫu để tạo một điều khiển hình 
vuông. Khi bạn nhấn Shift khi điều chỉnh kích cỡ của một điều khiển đã có, tỷ lệ 
chiều dài chiều rộng của nó không thanh đổi.

Note

Chú ý
Khi bạn thêm một group box, list box hoặc một combo box, trình tự động wizard sẽ 
xuất hiện để hướng dẫn bạn qua các bước cài đặt. Nếu bạn không muốn chạy 
wizard, nhấn vào nút  Wizards On/Off  trên thanh công cụ Form Controls.
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T o m t form đ n gi nạ ộ ơ ả

Cấu hình các điều khiển
Sau khi thêm các điều khiển, bạn cần phải cấu hình hình dáng và hành vi của chúng như bạn 
muốn. Kích chuột phải vào điều khiển biểu mẫu trong tài liệu của bạn và lựa chọn Control từ 
thực đơn.

Hộp thoại Form Control (Hình 2) có ba tab: General, Data và Events. Đối với các biểu mẫu 
đơn giản, chỉ tab General là đủ. Trong tab này bạn có thể thiết lập hình dáng của điều khiển.

Một vài điều khiển có các lựa chọn hữu ích:

• Một vài điều khiển có một số nhã có thể nhìn thấy, ví dụ Push Button và Option 
Button. Văn bản nhãn có thể được thiết lập.

• Hộp danh sách List Box chứa một danh sách các lựa chọn để chọn từ chúng. Thiết lập 
những cái này trong hộp đầu vào danh sách.

Ch  d nỉ ẫ Kích đúp chuột vào điều khiển làm hiện ra hộp thoại Control Properties.

Figure 2: Control Properties dialog

S  d ng m t bi u m uử ụ ộ ể ẫ
Để sử dụng một biểu mẫu, thoat khỏi trạng thái thiết kế bằng việc nhấn vào nút Design Mode 

On/Off 
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T o m t form đ n gi nạ ộ ơ ả

Một cách thông thường để sử dụng biểu mẫu là:

1) Bạn thiết kế một biểu mẫu, sau đó nhớ nó

2)  Bạn gửi biểu mẫu cho những người khác (ví dụ, bằng email)

3) Họ điền vào biểu mẫu, nhớ nó và gửi lại nó cho bạn.

4) Bạn mở biểu mẫu, xem các câu tra lời của họ.

TIP

Chỉ dẫn
Bằng việc sử dụng một nguồn dữ liệu, hoặc thiệt lập một biểu mẫu  để cập nhật lên 
web, bạn có thể tự động liên kết dữ liệu. Tuy nhiên, cả hai cách đó sẽ phức tạp hơn và 
bạn có thể muốn giữ chúng đơn giản.
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T o m t form đ n gi nạ ộ ơ ả

Hướng dẫn các điều khiển biểu mẫu

 Thanh công c  Formụ  
Control

Lựa chọn
Lựa chọn một điều khiển biểu mẫu để trình diễn một vài 
hành động trên nó.

 Trạng thái thiết kế tắt/bật
Chuyển đổi giữa trạng thái thiết kế bật (để chỉnh sửa biểu 
mẫu) và trạng thái thiết kế tắt (để sử dụng biểu mẫu)

Điều khiển
Mở hộp thoại thuộc tính của điều khiển biểu mẫu. Hộp 
thoại cos thể được giữ mở khi một điều khiển khác được 
lựa chọn.

Biểu mẫu
Mở hộp thoại các thuộc tính của biểu mẫu, các thuộc tính 
điều khiển toàn bộ biểu mẫu, như là nguồn dữ liệu mà nó 
liên kết.

Hộp đánh dấu
Một hộp có thể được lựa chọn hoặc không được lựa chọn 
trong biểu mẫu. Bạn có thể gắn nhãn cho hộp.

Hộp văn bản.
Điều khiển để tạo ra một hộp mà người dùng có thể đánh 
bất cứ văn bản nào vào đó.

Trường được định dạng
Điều khiển cho phép các lựa chọn định dạng cho số. Ví dụ 
bạn có thể thiết lập các giá trị lớn nhất, nhỏ nhất cho các số 
hoặc là kiể số (kiểu thập phân, khoa học, hay là tiền tệ)

Nút ấn Tạo một nút ấn có thể liên kết đến một đến một macro. 
Nhãn là tên xuất hiện ở trên nút.

Nút lựa chọn
Tạo một nút lựa chọn hoặc nút. Khi nhiều nút được nhóm 
với nhau, chỉ một nút có thể được lựa chọn. Cách tốt nhất 
để nhóm nhiều nút với nhau là sử dụng nút Group Box trên 
thanh công cụ More Controls, với trình tự động wizards 
được kích hoạt.

Hộp danh sách
Tạo ra một danh sách các lựa chọn, như là một thực đơn 
kéo xuống, người sử dụng có thể chọn từ đó. Nếu trình tự 
động wizard đã bật, việc tạo hộp danh sách sẽ mở ra List 
Box Wizard. Trình tự động wizard chỉ hữu dụng khi biểu 
mẫu của bạn liên kết đến một nguồn dữ liệu.
Nếu không liên kết với một nguồn dữ liệu, tắt wizard và tạo 
một hộp danh sách trống. Sau đó kích vào nút Control trong 
lựa chọn đầu vào danh sách trong tab General, điền lựa 
chọn mà bạn muốn xuất hiện vào danh sách.

Hộp Combo Như là hộp danh sách, bạn thiết lập danh sách các lựa chọn. 
Ngoài ra một ô ở trên sẽ hiển thị lựa chọn hoặc cho phép 
người sử dụng đánh ký tự vào đó. Ngoài ra hôp Combo làm 
việc như là List Box
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T o m t form đ n gi nạ ộ ơ ả

 Thanh công c  Formụ  
Control

Trường nhãn
Một nhãn văn bản. Sự khác nhau giữa  nhãn văn bản và 
đánh máy trực tiếp lên tài liệu, về mặt điều khiển, bạn có 
thể liên kết một trường nhãn với một chương trình macros, 
ví dụ, một điều gì đó sẽ xảy ra khi chuột qua hoặc là nhấn 
vào nó.

Thêm điều khiên
Mở thanh công cụ More Controls

Thiết kế biểu mẫu
Mở thanh công cụ Form Design (có thể được mở bằng cách 
View > Toolbars > Form Design)

Wizard Bật/Tắt
Một vài điều khiển biểu mẫu (List Box và Combo Box) có 
tuỳ chọn wizards. Nếu bạn không muốn wizard mở khi bạn 
tạo một trong những điều khiển này, sử dụng Wizards 
Bât/Tắt để chuyển đối.

Thanh công cụ More Controls

Nút quay
Nút quay cho phép người sử dụng chọn một số vòng qua 
một số. Chỉ ra giá trị lớn nhất, giá trị nhỏ nhất, giá trị mặc 
định và bước giữa các số.
Điều khiển này không phổ biến trong Write, như là số 
không được hiển thị. Trong Calc, tuy nhiên, mục Data xuât 
hiện trong hộp thoại Control Properties, cho phép bạn liên 
kết một nút quay với môt ô.

Thanh kéo
Tạo một thanh kéo, với một số lựa chọn để xác định chính 
xác sự xuất hiện.
Điều khiển này không phổ biến được dùng trong Writer. 
Trong Calc, một mục Dât xuất hiện trong hộp thoại Control 
Properties, cho phép bạn liên kết một thanh kéo đến một ô.

Nút hình
Hành động chính xác như một nút ấn, nhưng hiển thị một 
hình. Chọn một hình trong lựa chọn Graphics trên mục 
General trong hộp thoại Control Properties. 

Điều khiển hình ảnh
Chỉ hữu dụng khi biểu mẫu liên kết với một nguồn dữ liệu 
và một trường trong nguồn lưu ảnh. Bạn có thể thêm một 
ảnh mới vào cơ sử dữ liêu hoặc tìm và hiển thị một ảnh từ 
cơ sở dữ liêu.

Trường dữ liệu 
Giữ ngày. Cấu hình ngày sớm nhất và muộn nhât trường sẽ 
chấp nhận, ngày mặc định và định dạng ngày. Bạn có thể 
thêm một vòng quay.

Trường thời gian
Làm việc giống như một trường dữ liệu, chỉ ra thời gian.

Lựa chọn tệp
Cho phép người sử dụng lựa chọn một tệp bằng cách đánh 
đường dẫn và tên trực tiếp hoặc bằng cách nhấn vào mút 
Browse và chọn một trường từ hộp thoại.
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 Thanh công c  Formụ  
Control

Trường số
Hiển thị số. Chỉ ra định dạng, giá trị lớn nhất, giá trị nhỏ 
nhất, và giá trị mặc định. Bạn có thể thêm một vong quay.

Trường tiền tệ
 Làm việc giống như một trường số, bạn có thể thêm các ký 
hiệu tiền tệ.

Trường Pattern
Các trường Pattern hữu dụng khi biểu mẫu liên đến một 
nguồn dữ liệu. Chỉ ra một Edit Mask để giới hạn các giá trị 
mà người dùng có thể điền vào trường. Chỉ ra Literal Mask 
để giới hạn dữ liệu nào được hiển thị từ nguồn dữ liệu.

Hôp nhóm
Điều khiển hộp nhóm có hai các sử dụng khác nhau phụ 
thuộc vào khi nào wizard bật hoặc tắt.
Nếu wizards đang bật, tạo một hộp nhóm mở ra wizard 
Group Element. Điều này tạo ra một nhóm các nút tuỳ chọn 
(trong đó chỉ một được lựa chọn tại một thời điểm). Trong 
phần lớn các trường hợp, sử dụng hộp nhóm là cách tôt 
nhất để tạo ra một tập hợp các nút lựa chọn.
Nếu wizard đang tắt, một hộp nhóm đơn giản là một hộp 
nhìn thấy để nhóm các điều khiển khác nhau với nhau. Nó 
không có hiệu quả gì đối với hoạt động của các điều khiển.

 Điều khiển bảng
Điều khiển Table chỉ hữu dụng mới một nguồn dữ liệu. 
Nếu không nguồn dữ liệu nào được chỉ định, bạn sẽ được 
nhắc để chọn một trong Wizard Table Element.
Bạn có thể chọn một số trường để hiển thị trong trạng thái 
thiết kế tắt, dữ liệu xuất hiện trong bảng. Bảng đồng thời 
chứa các điều khiển để đi qua các bảng ghi.
Các bảng ghi có thể được thêm, xoá, chỉnh sửa trong bàng.

Thanh điều hường
Một thanh điều hướng giống như thanh công cụ Form 
Navigation (View > Toolbars > Form Navigation), nhưng 
có thể được đặt bất cứ đâu trong tài liệu và có thể thay đổi 
kích thước.

Thanh công cụ Form Design

Lựa chọn
Lựa chọn một điều khiển biểu mẫu để  trình diễn một hành 
động trên nó.

 Trạng thái thiết kế bật/tắt
Chuyển đổi giữa chế đố thiết kế bật (để sửa biểu mẫu) và 
chế độ thiết kế tắt (để sử dụng các biểu mẫu)

Điều khiển Mở hộp thoại thuộc tính của điều khiển biểu mẫu. Hộp 
thoại có thể được giữ mở khi các điều khiển khác đang 
được lựa chọn

Biểu mẫu
Mở hộp thoại thuộc tính biểu mẫu, các thuộc tính điều 
khiển cho toàn bộ biểu mẫu, ví dụ như nguồn dữ liệu nào 
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Thanh công cụ Form Design

nó liên kết đến.

Điều hướng biểu mẫu
Điều hướng biểu mẫu là một tiện ích, hiển thị tất cả các 
biểu mẫu và các điều khiển trong tài liệu hiện thời, cho 
phép bạn chỉnh sửa và xoá chúng dễ dàng.
Nếu bạn sử dụng Điều hướng biểu mẫu, bạn đặt tên cho 
các điều khiển (trong hộp thoại thuộc tính). Tên sẽ xuất 
hiện trong điều hướng. Nhờ tên bạn có thể phân biệt các 
điều khiển.

Thêm trường
Thêm trường chỉ hữu ích nếu bạn có một nguồn dữ liệu cụ 
thể cho biểu mẫu. Nếu không có nguồn dữ liệu nào được 
liên kết, một hộp trống sẽ mở ra.
Nếu bạn chỉ ra nguồn dữ liệu cụ thể, thêm trường sẽ mở ra 
danh sách của tất cả các trường trong bảng cụ thể, bạn có 
thể kéo và thả chúng vào trang. 
Đây là cách nhanh nhất và dễ nhất để tạo ra một biểu mẫu 
từ nguồn dữ liệu.

Thứ tự kích hoạt

Cho phép bạn chỉ ra thứ tự trong đó phím shift chuyển đến 
giữa các điều khiển. Bạn có thể kiểm tra thứ tự bằng việc 
rời khỏi trạng thái thiết kế và sử dụng phím Tab để chuyển 
đổi giữa các điều khiển.

Mở trong trạng thái thiết 
kế

Mở biểu mẫu hiện thời trong trạng thái thiết kế (để chỉnh 
sửa biểu mẫu )

 Chỉ ra điều khiển tự động
Nếu được kích hoạt, mục tiêu sẽ được thiết lập cho điều 
khiển biểu mẫu đầu tiên.

Định vị trí và kích cỡ
Mở hộp thoại Position và Size, cho phép bạn chỉ ra cả hai 
bằng việc đánh vào một giá trị chính xác, hơn là kéo một 
điều khiển. Bạn có thể khoá cỡ và vị trí, nên chúng không 
bị thay đổi ngẫu nhiên. Đối với một số điều khiển, bạn có 
thể quay và thiết lập độ dốc và bán kích góc.

Thay đổi  mỏ neo
Chỉ với khung, bất cứ điều khiển biểu mẫu nào cũng có thể 
được neo vào một trang, đoạn hoặc ký tự và đồng thời 
được neo như một ký tự (nghĩa là nó hành động giống như 
bất kỳ một ký tự khác trên một trang giấy)

Căn chỉnh
Nut Alignment sẽ không kích hoạt trừ khi một một điều 
khiển được neo như một ký tự. Bạn có thể căn chỉnh một 
điều khiển bằng những cách khác nhau, ví dụ lên đỉnh của 
điều khiển ngang hàng với đỉnh của một đoạn văn bản hoặc 
đáy  ngang hàng với đáy của một đoạn văn bản.

Hiển thị lưới
Hiển thị lưới các điểm trên trang giấy, giúp bạn kẻ đường 
các điều khiển.

Gắn vào lưới
Khi một điều khiển được mang gần đến một điểm lưới 
hoặc một đường, nó sẽ nhập vào lưới, Điều này tạo sự dễ 
dàng đối với định hàng cho các điều khiển.

Using Forms in Writer 9



T o m t form đ n gi nạ ộ ơ ả

Thanh công cụ Form Design

 Đường khi dịch chuyển
Khi một điều khiển được dịch chuyển, đường mở rộng từ 
một điều khiển ngang và dọc giúp bạn đặt vị trí của nó 
chính xác.

Ví dụ: một biểu mẫu đơn giản

T o m t tài li uạ ộ ệ
Mở một tài liệu mới (File > New > Text Document). Đây là ý tưởng viết ra một phác thảo 
của tài liệu, không có các điều khiển biểu mẫu, do đó nó rất dễ dàng thanh đổi sau đó.

Figure 3: Initial document without form controls

Add form controls Thêm các điều khiển biểu mẫu
Bước tiếp theo là thêm các điều khiển biểu mẫu vào tài liệu. Chúng ta sẽ có bốn điều khiển:

• Name là môt hôp văn bản.

• Sex là một nút hai lựa chọn, nam hay nữ.

• All shapes you like là một danh sách các lựa chọn.

• Tất cả các hình bạn thích là một dãy các hộp kiểm tra.

Để thêm các điều khiển này

1) Lựa chọn    View > Toolbars > Form Controls để mở thanh công cụ Form Control.

2) Nếu các cộng cụ không sẵn sàng, nhấn vào nút  Form Navigator (trên thanh công cụ 
Form Control) để kích hoạt chúng. Nếu cần thiết, nhấn vào nút  Design Mode On/Off. 
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3) Nhấn vào nút TextBox , sau đó nhấn vào tài liệu, với chuột trái được nhấn xuống, 
kéo hình của của hộp văn bản Name theo kích cỡ mà bạn muốn.

4) Chắc chắn rằng là nút Wizards On/Off  đang trạng thái bật. Nhấn vào nút More 

Controls để mở thanh công cụ More Controls . 

5) Trên thanh công cụ More Controls, nhấn vào nút Group Box . Vẽ một hộp nhóm 
Sex.

6) Trên trang đầu tiên của wizard, đánh tên hai trường lựa chọn: Nam và Nữ. Nhấn 
Next>> ba lần, xoá caption và nhấn Finish.

7) Bây giờ tạo một hôp danh sách. Trên thanh công cụ Form Controls, nhấn vào nút 

Wizards On/Off  để tắt wizard. Nhấn vào nút  List Box  và vẽ một hộp danh 
sách Favourite Shape: trong tài liệu. Việc này sẽ tạo một ô cửa trống. 

8) Cuối cùng tạo ra bốn hộp kiểm tra All the shapes you like. Nhấn vào nút  Check Box 

và sau đó vẽ ra bốn hộp kiểm tra, cạnh nhau dọc trang. 

Bạn sẽ có một tài liệu giống như sau:

Figure 4: Document with form controls

Cấu hình các điều khiển biểu mẫu
Trường Name và Sex không cần cấu hình thêm. 

Hộp danh sách phải được cấu hình để thêm một danh sách các lựa chọn. Hộp kiểm tra phải 
được cấu hình để thêm vào các tên.
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1) Nhấn vào điều khiển List Box trong tài liệu và sau đó nút Control  trên thanh công 
cụ Form Design để mở ra hộp tính chất điều khiển. Lựa chọn mục Genneral.

2) Trong hộp List Entries, thêm tên các các hình: Circle, Triangle, Square và Pentagon. 
Đánh vào một hình và nhấn phím Enter. Sau đó đặt con trỏ ở cuối của dòng và gõ vào 
hình tiếp theo.

3) Nhấn vào hộp Check Box đầu tiên. Hộp thoại Properties sẽ mở ra 

4) Thay đổi nhãn Label thành Circle và nhấn Enter. Nhãn trên hộp kiểm tra sẽ thay đổi 
ngay lập tức. 

5) Nhấn vào từng hộp kiểm tra. Thanh đổi nhãn Label trong hộp thoại Properties lần lượt 
thành Triangle, Square, and Pentagon.

6) Đóng hộp thoại Properties.

7) Chuyển Design Mode sang trạng thái tắt và đóng hai thanh công cụ Controls.

Bây giờ bạn đã hoàn thành xong biểu mẫu có hình dạng sau:

Figure 5: Completed form

Hoàn thành
Biểu mẫu được hoàn thành, nhưng bạn có thể tự do thay đổi tài liệu. Nếu bạn gửi biểu mẫu 
cho người khác điền thông tin, bạn có thể muốn làm cho tài liệu ở chế độ chỉ đọc read-only. 
Hiệu quả là người dùng chỉ có thể điền thông tin vào biểu mẫu mà không thể thay đổi các 
định dạng của biểu mẫu.

Để tạo một tài liểu chỉ đọc lựa chọn Tools > Options > OpenOffice.org > Security > Open 
this document in read-only mode.
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Note

Chú ý
Nếu tài liệu chỉ đọc nếu một người điền thông tin vào biểu mẫu sẽ cần sử dung File 
> Save as để lưu tài liệu.

Truy cập nguồn dữ liệu
Cách sử dụng phổ biển của biểu mẫu là như một đầu cuối của một cơ sơ dữ liệu. Bạn có thể 
cung cấp một biểu mẫu cho phép người sử dụng thêm thông tin vào cơ sở dữ liệu đang kết 
nối, bởi vì nó là một phần của tài liệu Writer, biểu mẫu có thể chứa tất cả các hình, các định 
dạng, và các thành phần khác  làm nó giống như cái bạn muốn. Chỉnh sửa một biểu mẫu cũng 
đơn giản như chỉnh sửa một tài liệu.

OpenOffice.org có thể truy cập rất nhiều loại cơ sở dữ liệu như ODBC, MySQL, Oracle, 
JDBC, spreadsheets và tệp văn bản. Nhìn chung cơ sở dữ liệu có thể được truy nhập để đọc 
vào viết, các nguồn dữ liệu khác (ví dụ spreadsheets) chỉ có thể đọc.

Chỉ dẫn
Để nhìn thấy danh sách đầy đủ các kiểu nguồn cơ sở dữ liệu hỗ trợ, nhấn  File > 
New > Database. Nhấn Connect đến một cơ sở có sẵn và sau đó nhấn hình tam giác 
ở hộp danh sách.

Tạo cơ sở dữ liệu
Chương có tựa đề ”Bắt đầu với Nền tảng” trong hương dẫn bắt đầu trình bày chi tiết hơn cách 
để tạo một cơ sơ dữ liệu. Chúng ta sẽ đưa ra một hướng dẫn ngắn gọn ở đây để tạo ra một cơ 
sở dữ liệu đơn giản với OOo Base.

1) Lựa chọn  File > New > Database để bắt đầu trình tự động Database Wizard (Hình 6)

2) Nhấn Create a new database và nhấn Next.

3) Chọn Yes, register the database for me. Đăng ký cơ sở dữ liệu mang ý nghĩa là nó có 
thể được truy nhập từ các thành phần Ooo khác như là Writer và Calc. Bạn cần làm 
điều này nếu bạn muốn liên kết biểu mẫu của bạn với cơ sở dữ liệu.

4) Nhấn Finish và lưu cơ sở dữ liệu mới của bạn, cho nó một cái tên. Không giống như 
việc tạo một tài liệu trong OOo, cơ sở dữ liệu phải được lưu giữ khi bạn tạo nó lần 
đầu. 
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Truy c p ngu n d  li uậ ồ ữ ệ

Figure 6: Database Wizard

Sau khi lưu cơ sở dữ liệu, bạn nên xem bàn hình Base chính (hình 7), nơi chứa ba ô cửa. Ô 
cửa bên trái là Cơ sở dữ liệu, với biểu tượng Bảng, Truy vấn, Biểu mẫu và Báo cáo.

Bước tiếp theo là tăng thêm một bản. Chi tiết được trình bài trong “Bắt đầu với Base” trong 
hướng dẫn Bắt đầu

1) Chọn vào một  Tables, sau đó nhấn Create Table in Design View.

2) Sử dụng màn hình thiết kế bảng (hình 8) để cho Base biết các trường nào được tạo. 
Chúng ta sẽ có ba trường: Name, Address, và Telephone.

3) Trên dòng đầu tiên, thêm vào dưới trường ID và thiết lập trường Field Type thành 
Integer [INTEGER]. Trong hộp xám ở cuối dòng, kích chuột phải và lựa chọn 
Primary Key, làm hiện biểu tượng chìa khoá ở trong hộp. Trong Field Properties ở 
cuối của màn hình là lựa chọn Auto Value, thay đổi thành Yes.

TIP

Chú ý
Thiết lập trường Primary Key với Auto Value thành Yes là một bước quan trọng. 
Nếu bước này không được thực hiện, biểu mẫu bạn tạo ra sau đó đòi hỏi tinh tế 
trong việc sử dụng và rất dễ phát sinh lỗi cho người sử dụng. Chắc chắn rằng bạn đã 
thực hiện bước này đúng!

4) Trên ba dòng, điền vào Field Name  Name Name, Address and Telephone. Chấp nhận 
mặc định Field Type của Text[VARCHAR] và để Description trống.
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5) Lưu bảng (File > Save). Bạn sẽ được nhắc đặt tên cho nó.

6)  Cuối cùng, lưu toàn bộ văn bản từ màn hình Base (File > Save).

Figure 7: Main Base screen with contacts table created
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Figure 8: Database table design

Truy cập nguồn dữ liệu có sẵn
Nếu bạn đã có một nguồn dữ liệu có sẵn, ví dụ một spreadsheet hoặc một cơ sở dữ liệu, bạn 
đơn giản muốn cho Ooo biết về nó. Đây gọi là đăng ký nguồn dữ liệu.

Để đăng ký một nguồn dữ liệu:

1) Lựa chọn File > New > Database để mở Database Wizard.

2)  Lựa chọn Connect to an existing database và chọn kiểu từ danh sách kéo xuống.

3) Nhấn Next và theo chỉ dẫn để lựa chọn cơ sở dữ liệu đăng ký (quá trình chính xác thay 
đổi giữa các loại khác nhau của nguồn dữ liệu)

4) Trong bước 3: Nhớ và thực thi, kiểm tra lại  Yes, register the database for me đã 
được chọn. Không lựa chọn Open the database for editing bạn phải đăng ký nó, 
không được chỉnh sửa nó qua Base.

Tạo một biểu mẫu cho dữ liệu nhập vào
Bất cứ khi nào bạn tạo một cơ sở dữ liệu, hoặc đã có nguồn dữ liệu, thì nguồn phải được đăng 
ký với OpenOffice.org (ở phía trên). Một khi nó đã được đăng ký, liên kết biểu mẫu của bạn 
với nguồn dữ liệu rất đơn giản. Thực hiện theo các bước sau sẽ tạo ra một biểu mẫu và liên 
kết nó với một nguồn dữ liệu đã đăng ký.
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1) Tạo một tài liệu mới trong Writer (File > New > Text Document).

2)  Thiết kế biểu mẫu, không đưa vào các trường thực sự (bạn có thể thay đổi sau đó)

3) Làm hiện thanh công cụ Form Controls (View > Toolbars > Form Controls).

4) Nhấn vào nút  Design Mode On/Off  để đặt tài liệu vào trạng thái thiết kế, nếu 
cần. Vớ trạng thái thiết kế tắt, phần lớn các nút của thanh công cụ sẽ màu xám. Nếu 
nút Design Mode cũng mầu xám, nhấn vào nút Select để kích hoạt nó.

5) Nhấn vào nút  Text Box. Nhấn vào tài liệu và, giữ chuột trái, kéo chuột để tạo một hộp 
văn bản đối với trường văn bản đầu tiên(Ví dụ, Name, nếu bạn đang liên kết với cơ sở 
dữ liệu được tao ra trước đó).

6) Nhấn vào nút Text Box một lần nữa và kéo chuột để vẽ trường khác. Các trường thêm, 
hoặc bất cứ kiểu, có thể được thêm bằng cùng cách (nhấn và kéo).

Đến lúc này bạn đã thực hiện các bước khi bạn tạo biểu mẫu đầu tiên của bạn.

Bây giờ liên kêt biểu mẫu của bnạ với nguồn dữ liệu đã đăng ký. 

1) Bạn có thể làm điều này bằng cách kích vào nút Form  trong thanh công cụ Form 
Controls, hoặc bằng cách kích vào bất cứ trường nào mà bạn thêm vào và chọn Form. 
Nút biểu mẫu sẽ xám trừ khi bạn có một thành phần của biểu mẫu được lựa chọn. 
Ngay khi bạn lựa chọn một thành phần của biểu mẫu trong tài liệu của bạn, nút Form 
sẽ có thể kích.

2) Trong hộp thoại Form Properties, nhấn vào mục Data :

• Thiết lập Data Source thành nguồn dữ liệu mà bạn đã đăng ký.

• Thiết lập Content Type thành Table.

• Thiết lập Content thành tên của bảng bạn muốn truy cập.

• Đóng hộp thoại.

3) Đối với từng điều khiển đến lượt, mở ra hộp thoại .Nhấn vào điều khiển để lựa chọn 
nó (một hộp màu xanh sẽ xuất hiện xung quanh điều khiển). Sau đó chuôt phải và 

chọn Control và nhấn vào nút Control  trong thanh công cụ Form Controls.

4) Trong hộp thoại Properties, nhấn vào mụcData. Nếu bạn thiết lập biểu mẫu chính 
xác, tuỳ chọn sẽ Data Field chứa danh sách của các trường khác nhau trong nguồn dữ 
liệu (ví dụ, Name, Address và Telephone). Lựa chọn trường mà bạn muốn.

5) Lựa chọn đối với từng điều khiển đến lượt cho đến khi mọi điều khiển được gắn cho 
một trường nào đó.

TIP

Chỉ dẫn
Nếu bạn tạo ra một cơ sở dữ liệu trong OOo Base và trường khoá chính có Auto 
Value được thiết lập Yes, trường này sẽ không cần là một phần của biểu mẫu. Nếu 
Auto Value được thiết lập No, bạn sẽ phải bao gồm nó và người dùng phải điền một 
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giá trị duy nhất cho trường đó bất cứ khi nào họ điền mới. 

Điền dữ liệu vào một biểu mẫu

Một khi bạn đã tạo một biểu mẫu, gắn nó với một cơ sở dữ liệu, bạn muốn sử dụng nó để 
điền dữ liệu vào nguồn dữ liệu, hoặc chỉnh sửa dữ liệu đã có sẵn ở đó.

1) Chắc chắn ràng biểu mẫu không trong trạng thái thiết kế. Trong thanh công cụ Form 

Controls, nhấn vào nútDesign Mode On/Off . Nếu nút thiết kế tắt, phần lớn các 
nút trong thanh công cụ sẽ xám.

2) Chắc chắn ràng thanh công cụ  Form Navigation đã bật (View > Toolbars > Form 
Navigation). Thanh công cụ điều hường thường xuất hiện ở đáy của màn hình.

Figure 9: Form Navigation toolbar

3) Nếu có một dữ liệu có sẵn trong nguồn dữ liệu, sử dụng nút điều khiển trong thanh 
công cụ Form Navigation để nhìn thấy các bản ghi khác nhau.Bạn có thể chỉnh dữ liệu 
trong một bản ghi bởi việc biên tập dữ liệu trên biểu mẫu. Để chấp nhận thay đổi, nhấn 
vào khóa Enter với con trỏ trong trường cuối cùng. Bản ghi sẽ được lưu và bản ghi 
tiếp theo sẽ được hiển thị.

4) Nếu không có dữ liệu trong biểu mẫu, bạn có thể điền nó. Để chấp nhận một bản ghi 
mới, nhấn vào khoá Enter với con trỏ ở trường cuối cùng. 

5) Các chức năng khác có thể thực hiện từ thanh công cụ Form Navigation, bao gồm xoá 
một bản ghi và thêm một bản ghi mới.

Chỉnh sửa biểu mẫu mức cao

Liên kết một chương trình macro với một điều khiển biểu mẫu.
Bạn có thể thiết lập bất cứ điều khiển biểu mẫu nào (ví dụ, hộp văn bản hay là nút) để trình 
diễn một hành động khi được khởi động bằng một vài sự kiện. Để nhìn tất các danh sách của 
các sự kiện, nhấn chuột phải vào điều khiển biểu mẫu khi trạng thái thiết kế đang bật, lựa 
chọn Control và nhấn vào mục Events (Hình 10)
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Figure 10: Control properties events tab

Để gắn một chương trình macro cho một sự kiện

1) Tạo một macro (Xem trong chương nhan đề “Bắt đầu với Macros” trong hướng dẫn 
Getting Started).

2) Nhấn chuột phải vào điều khiển biểu mẫu, lựa chọn Control và nhấn vào mục Events.

3) Nhấn vào nút ... ở bên phải của sự kiện để mở hôp thoại Assign Macro(Hình 11)

4) Nhấn Assign và chọn chương trình macro.

Figure 11: Assign macro dialog box
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Các macro có thế được gán cho các sự kiện liên quan đến biểu mẫu. Để thực hiện điều này, 
chuột phải vào một điều khiển biểu mẫu trong tài liệu, lựa chọn Form và nhấn vào mục 
Events.

Các tài liệu chỉ đọc
Sau khi tạo ra biểu mẫu của bạn, bạn muốn bất kỳ  người sử dụng nó cũng có thể truy cập vào 
thông tin được lưu giữ trong cơ sở dữ liệu, hoặc hoàn thành biểu mẫu, không thay đổi bố cục. 
Cách dễ dàng nhất là: làm cho tài liệu chỉ đọc.

Lựa chọn Tools > Options > OpenOffice.org > Security> Open this document in read 
only mode.

Quyền truy cập cơ sở dữ liệu
Mặc định, khi một cơ sở dữ liệu được truy cập từ biểu mẫu, bất cứ thay đổi nào có thể được 
làm đối với nó: bản ghi có thể được thêm, xoá, sửa. Bạn có thể muốn người sử dụng có thể 
thêm các bản ghi mới và bị ngăn cấm xoá các bản ghi đã có sẵn.

Trong trạng thái thiết kế, nhấn chuột phải vào điều khiển biểu mẫu và lựa chọn Form từ thực 
đơn. Trên mục Data của hộp thoại Form Properties là một số lựa chọn: Cho phép thêm, Cho 
phép xoá, cho phép chỉnh sửa và chỉ cho thêm dữ liệu.  Thiết lập từng tuỳ chọn  Yes hoặc No 
để điều khiển sự truy cập của người dùng với nguồn dữ liệu.

Các trường cá nhân có thể được bảo vệ. Điều này có thể hữu ích nếu bạn muốn một người 
dùng có thể chỉnh sửa một phần của bản ghi nhưng không xem được người káhc, ví dụ như 
danh sách cố phần trong đó mô tả mục có thể cố định và số lượng có thể được chỉnh sửa.

Để cho một trường riêng biệt chỉ có thể đọc, trong trạng thái thiết kế, kích phải chuột vào 
điều khiển biểu mẫu trong tài liệu và lựa chọn Control từ từ thực đơn. Lựa chọn mục 
General và thiết lập Read-only thành Yes.

Các lựa chọn định dạng điều khiển biểu mẫu
Bạn có thể thay đổi hình ảnh của các điều khiển biểu mẫu và hành vi bằng một số cách. Tất 
cả được thực hiện trong trạng thái thiết kế. Nhấn phải chuột vào điều khiển biểu mẫu, lựa 
chọn Control từ thư mục pop-up và lựa chọn mục General trong hộp thoại Properties.

• Thiết lập nhãn cho điều khiển trong trường Label. Một vài điều khiển biểu mẫu, ví dụ 
nút ấn và nút lựa chọn, có nhãn được nhìn thấy và có thể thiết lập. Ngoài ra, ví dụ hộp 
văn bản, thì không thể.

• Thiết lập bất cứ điều khiển biểu mẫu sẽ in ra nếu tài liệu được in với lựa chọn Print.

• Sử dụng Font setting để thiết lập font, kiểu chữ và cỡ chữ cho trường.
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• Đối với các hộp văn bản, bạn có thể thiết lập độ dài văn bản lớn nhất. Điều này rất có 
ích khi bạn thêm một bản ghi mời vào cơ sở dữ liệu. Mọi trường văn bản cơ sở dữ liệu 
đều có độ dài văn bản lớn nhất, nếu dữ liệu được thêm vào quá dài, OOo hiển thị 
thông báo lỗi. Bằng việc thiết lập độ dài văn bản lớn nhất của điều khiển biểu mẫu 
giống như của trường cơ sở dữ liệu, lỗi này có thể tránh.

•  Bạn có thể thiết lập tuỳ chọn mặc định đối với điều khiển biểu mẫu. Mặc định, một 
điều khiển là trống, hoặc có mọi lựa chọn là không được chọn. Bạn có thể thiết lập 
một điều khiển bắt đầu với một lựa chọn cụ thể hoặc một mục danh sách được lựa 
chọn.

• Đối với các điều khiển nơi các mật khẩu được nhập vào, thiết lập ký tự mật khẩu (ví 
dụ thành *) hiển thị chỉ các ký tự đó, nhưng lưu bất kỳ xâu gì mà người dùng gõ vào.

•  Bạn có thể thêm thông tin và văn bản giúp đỡ cho điều khiển biểu mẫu.

• Các điều khiển biểu mẫu khác ví dụ màu nền, 3-D, định dạng văn bản, thanh cuộn, 
viền cho phép bản xử lý hình ảnh xuất hiện của điều khiển tốt hơn.
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XForms 
XForms là một kiểu mới của biểu mẫu web, được phát triển bởi World Wide Web 
Consortium (W3C). OpenOffice.org2.0 hỗ trợ chuẩn mở XForms 1.0  để tạo các biểu mẫu 
web với XML.

OOo2.0 hỗ trợ chuẩn Xforms.

Trong OpenOffice.org, một tài liệu Xforms là một kiểu đặc biệt của tài liệu Writer. Xforms sử 
dụng các điều khiển giống như các biểu mẫu bình thường được mô tả trong chương.

Sau khi bạn tạo và lưu một tài liệu Xforms, bạn có thể mở tài liệu, điền vào biểu mẫu, và chất 
nhận các thay đổi đối với máy phục vụ.

Một hướng dẫn chi tiết cho Xforms  không nằm trong phạm vi của chương.
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